{"answers":{"affected":"2 open source packages ship an affected version, including codiad/codiad. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-14043 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-14043 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-14043 is a high-severity vulnerability in n/a, published on 24 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-14043 and fix it if it is affected.\n\nWhat it is: CVE-2020-14043 is a high-severity vulnerability in n/a, published on 24 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-14043 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codiad/codiad (Packagist): affected from 1.7.8 up to 2.8.4; no fix listed\n- codiad/codiad (Packagist): affected from 1.7.8 up to 2.8.4; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-14043/ (Markdown: https://insights.sbomify.com/CVE-2020-14043/index.md)","id":"CVE-2020-14043","markdown":"https://insights.sbomify.com/CVE-2020-14043/index.md","name":"CVE-2020-14043","record":{"aliases":["GHSA-35gp-jxw8-xw6h"],"analysis":{"component_type":"web_application","fix_type":"end_of_life","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Codiad web IDE","requires_auth":"none","summary":"A CSRF vulnerability in Codiad allows attackers to trick admins into downloading plugins, potentially leading to remote code execution.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"codiad","vendor":"codiad"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"** PRODUCT NOT SUPPORTED WHEN ASSIGNED ** A Cross Side Request Forgery (CSRF) vulnerability was found in Codiad v1.7.8 and later. The request to download a plugin from the marketplace is only available to admin users and it isn't CSRF protected in components/market/controller.php. This might cause admins to make a vulnerable request without them knowing and result in remote code execution. NOTE: the vendor states \"Codiad is no longer under active maintenance by core contributors.\"","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Codiad CSRF Vulnerability","id":"CVE-2020-14043","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Codiad SSRF Vulnerability","id":"CVE-2020-14044"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["1.7.8"],"last_affected":["2.8.4"],"package":"codiad/codiad","purl":null,"source":"GHSA-35gp-jxw8-xw6h"},{"ecosystem":"Packagist","fixed":[],"introduced":["1.7.8"],"last_affected":["2.8.4"],"package":"codiad/codiad","purl":"pkg:composer/codiad/codiad","source":"GHSA-35gp-jxw8-xw6h"}],"prev":{"headline":"Codiad Cross-site Scripting Vulnerability","id":"CVE-2020-14042"},"products":["n/a"],"published":"2020-08-24","related":[{"cvss_score":9.8,"headline":"Code injection in codiad","id":"CVE-2019-19208","kev_date_added":null,"published":"2020-03-16"},{"cvss_score":9.8,"headline":"Codiad remote code execution vulnerability","id":"CVE-2018-14009","kev_date_added":null,"published":"2018-07-12"},{"cvss_score":9.8,"headline":"Codiad Vulnerable to Shell Command Injection","id":"CVE-2017-11366","kev_date_added":null,"published":"2017-08-21"},{"cvss_score":7.5,"headline":"Codiad Vulnerable to PHP Magic Hash Vulnerability","id":"CVE-2020-23355","kev_date_added":null,"published":"2021-01-27"},{"cvss_score":7.5,"headline":"File upload in n/a","id":"CVE-2017-1000125","kev_date_added":null,"published":"2017-11-17"},{"cvss_score":7.2,"headline":"Codiad SSRF Vulnerability","id":"CVE-2020-14044","kev_date_added":null,"published":"2020-08-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A CSRF vulnerability in Codiad allows attackers to trick admins into downloading plugins, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2020-14043/"}