{"answers":{"affected":"2 open source packages ship an affected version, including codiad/codiad. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-14044 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-14044 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-14044 is a high-severity server-side request forgery vulnerability in n/a, published on 24 Aug 2020. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-14044 and fix it if it is affected.\n\nWhat it is: CVE-2020-14044 is a high-severity server-side request forgery vulnerability in n/a, published on 24 Aug 2020. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-14044 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codiad/codiad (Packagist): affected from 1.7.8 up to 2.8.4; no fix listed\n- codiad/codiad (Packagist): affected from 1.7.8 up to 2.8.4; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-14044/ (Markdown: https://insights.sbomify.com/CVE-2020-14044/index.md)","id":"CVE-2020-14044","markdown":"https://insights.sbomify.com/CVE-2020-14044/index.md","name":"CVE-2020-14044","record":{"aliases":["GHSA-c3q8-hh69-7mg5"],"analysis":{"component_type":"web_application","fix_type":"end_of_life","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Codiad web IDE","requires_auth":"high_privilege","summary":"An admin user can exploit an SSRF vulnerability in the plugin installer to potentially achieve remote code execution on the server.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"codiad","vendor":"codiad"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"** PRODUCT NOT SUPPORTED WHEN ASSIGNED ** A Server-Side Request Forgery (SSRF) vulnerability was found in Codiad v1.7.8 and later. A user with admin privileges could use the plugin install feature to make the server request any URL via components/market/class.market.php. This could potentially result in remote code execution. NOTE: the vendor states \"Codiad is no longer under active maintenance by core contributors.\"","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Codiad SSRF Vulnerability","id":"CVE-2020-14044","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Missing authorization in n/a","id":"CVE-2020-14048"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["1.7.8"],"last_affected":["2.8.4"],"package":"codiad/codiad","purl":null,"source":"GHSA-c3q8-hh69-7mg5"},{"ecosystem":"Packagist","fixed":[],"introduced":["1.7.8"],"last_affected":["2.8.4"],"package":"codiad/codiad","purl":"pkg:composer/codiad/codiad","source":"GHSA-c3q8-hh69-7mg5"}],"prev":{"headline":"Codiad CSRF Vulnerability","id":"CVE-2020-14043"},"products":["n/a"],"published":"2020-08-24","related":[{"cvss_score":9.8,"headline":"Code injection in codiad","id":"CVE-2019-19208","kev_date_added":null,"published":"2020-03-16"},{"cvss_score":9.8,"headline":"Codiad remote code execution vulnerability","id":"CVE-2018-14009","kev_date_added":null,"published":"2018-07-12"},{"cvss_score":9.8,"headline":"Codiad Vulnerable to Shell Command Injection","id":"CVE-2017-11366","kev_date_added":null,"published":"2017-08-21"},{"cvss_score":8.8,"headline":"Codiad CSRF Vulnerability","id":"CVE-2020-14043","kev_date_added":null,"published":"2020-08-24"},{"cvss_score":7.5,"headline":"Codiad Vulnerable to PHP Magic Hash Vulnerability","id":"CVE-2020-23355","kev_date_added":null,"published":"2021-01-27"},{"cvss_score":7.5,"headline":"File upload in n/a","id":"CVE-2017-1000125","kev_date_added":null,"published":"2017-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An admin user can exploit an SSRF vulnerability in the plugin installer to potentially achieve remote code execution on the server.","url":"https://insights.sbomify.com/CVE-2020-14044/"}