# CVE-2020-14060: Deserialization of untrusted data in Jackson Databind

> Attackers can execute arbitrary code via deserialization of untrusted data in jackson-databind when specific typing features are enabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2020
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2020-14060, GHSA-j823-4qch-3rgm, UBUNTU-CVE-2020-14060

## What is CVE-2020-14060?

CVE-2020-14060 is a high-severity unsafe deserialization vulnerability in Fasterxml Jackson-Databind, published on 14 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FasterXML jackson-databind 2.x before 2.9.10.5 mishandles the interaction between serialization gadgets and typing, related to oadd.org.apache.xalan.lib.sql.JNDIConnectionPool (aka apache/drill).

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-14060?

2 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 12 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.10.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.10.5 |

Products: Fasterxml Jackson-Databind, Netapp Active Iq Unified Manager, Netapp Steelstore Cloud Integrated Storage, Oracle Agile Product Lifecycle Management, Oracle Banking Digital Experience, Oracle Communications Calendar Server, Oracle Communications Contacts Server, Oracle Communications Diameter Signaling Router, Oracle Communications Element Manager, Oracle Communications Evolved Communications Application Server, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager.

## How do I fix CVE-2020-14060?

Upgrade com.fasterxml.jackson.core:jackson-databind to 2.9.10.5 or later.

## Is CVE-2020-14060 being exploited?

There is no known exploitation of CVE-2020-14060 in the wild and no public exploit code.

## Other vulnerabilities in Fasterxml Jackson-Databind

- [CVE-2018-11307](https://insights.sbomify.com/CVE-2018-11307/): Deserialization of Untrusted Data in jackson-databind (critical 9.8)
- [CVE-2026-54512](https://insights.sbomify.com/CVE-2026-54512/): jackson-databind: PolymorphicTypeValidator bypass via generic type parameters allows arbitrary class instantiation (high 8.1)
- [CVE-2026-54513](https://insights.sbomify.com/CVE-2026-54513/): jackson-databind: Array subtype allowlist bypass in BasicPolymorphicTypeValidator (allowIfSubTypeIsArray) (high 8.1)
- [CVE-2021-46877](https://insights.sbomify.com/CVE-2021-46877/): jackson-databind possible Denial of Service if using JDK serialization to serialize JsonNode (high 7.5)
- [CVE-2019-14893](https://insights.sbomify.com/CVE-2019-14893/): Polymorphic deserialization of malicious object in jackson-databind (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14060 and fix it if it is affected.

What it is: CVE-2020-14060 is a high-severity unsafe deserialization vulnerability in Fasterxml Jackson-Databind, published on 14 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14060 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.10.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.10.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14060/ (Markdown: https://insights.sbomify.com/CVE-2020-14060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14060
- OSV: https://osv.dev/vulnerability/CVE-2020-14060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14060/
Summaries are generated and may contain mistakes; the official description above is the record.
