# CVE-2020-14144: Arbitrary Code Execution in Gitea

> Authenticated users can execute arbitrary code via git hooks if the feature is enabled, requiring careful configuration management.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-gitea-2020-14144, GHSA-3h6c-c475-jm7v

## What is CVE-2020-14144?

CVE-2020-14144 is a high-severity command injection vulnerability in Gitea Gitea, published on 16 Oct 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The git hook feature in Gitea 1.1.0 through 1.12.5 might allow for authenticated remote code execution in customer environments where the documentation was not understood (e.g., one viewpoint is that the dangerousness of this feature should be documented immediately above the ENABLE_GIT_HOOKS line in the config file). NOTE: The vendor has indicated this is not a vulnerability and states "This is a functionality of the software that is limited to a very limited subset of accounts. If you give someone the privilege to execute arbitrary code on your server, they can execute arbitrary code on your server. We provide very clear warnings to users around this functionality and what it provides.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-14144?

3 open source packages ship an affected version, including code.gitea.io/gitea and gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | From 1.1.0 | 1.12.6 |
| `code.gitea.io/gitea` | Go | From 1.1.0 | 1.12.6 |
| `gitea` | Bitnami | From 1.1.0 | 1.12.6 |

Products: Gitea Gitea.

## How do I fix CVE-2020-14144?

Upgrade code.gitea.io/gitea to 1.12.6 or later.

## Is CVE-2020-14144 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-14144 exists.

Public exploit code:

- A script to exploit CVE-2020-14144 - GiTea authenticated Remote Code Execution using git hooks (github_poc): https://github.com/p0dalirius/CVE-2020-14144-GiTea-git-hooks-rce
- Gitea Git Hooks Remote Code Execution (metasploit)
- Gitea versions 1.1.0 → 1.12.5 allow authenticated users with "May create git hooks" permission to inject arbitrary shell commands into post-receive hooks. Pushing a commit triggers the hook and executes the payload on the server. (github_poc): https://github.com/Mohnad-AL-saif/Gitea-Git-Hooks-RCE-CVE-2020-14144-
- Gitea 1.1.0 - 1.12.5 - Remote Code Execution (nuclei): http/cves/2020/CVE-2020-14144.yaml

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14144 and fix it if it is affected.

What it is: CVE-2020-14144 is a high-severity command injection vulnerability in Gitea Gitea, published on 16 Oct 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-14144 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected from 1.1.0; fixed in 1.12.6
- code.gitea.io/gitea (Go): affected from 1.1.0; fixed in 1.12.6
- gitea (Bitnami): affected from 1.1.0; fixed in 1.12.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14144/ (Markdown: https://insights.sbomify.com/CVE-2020-14144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14144
- OSV: https://osv.dev/vulnerability/CVE-2020-14144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14144/
Summaries are generated and may contain mistakes; the official description above is the record.
