{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-14147 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-14147 is a high-severity vulnerability in Debian Debian Linux, published on 15 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-14147 and fix it if it is affected.\n\nWhat it is: CVE-2020-14147 is a high-severity vulnerability in Debian Debian Linux, published on 15 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-14147 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-14147/ (Markdown: https://insights.sbomify.com/CVE-2020-14147/index.md)","id":"CVE-2020-14147","markdown":"https://insights.sbomify.com/CVE-2020-14147/index.md","name":"CVE-2020-14147","record":{"aliases":["ALPINE-CVE-2020-14147","AZL-6842","CLEANSTART-2026-NQ97592","DEBIAN-CVE-2020-14147","DSA-4731-1","GHSA-5q54-rrmc-9jrp","MGASA-2020-0312","UBUNTU-CVE-2020-14147","openSUSE-SU-2020:1035-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Redis database","requires_auth":"low_privilege","summary":"Attackers with Lua execution permissions can cause denial of service or bypass sandbox restrictions via integer overflow in Redis.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"communications_operations_monitor","vendor":"oracle"},{"product":"redis","vendor":"redislabs"},{"product":"linux_enterprise","vendor":"suse"}],"cvss":{"score":7.7,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"An integer overflow in the getnum function in lua_struct.c in Redis before 6.0.3 allows context-dependent attackers with permission to run Lua code in a Redis session to cause a denial of service (memory corruption and application crash) or possibly bypass intended sandbox restrictions via a large number, which triggers a stack-based buffer overflow. NOTE: this issue exists because of a CVE-2015-8080 regression.","ecosystems":["SUSE:Package Hub 12","SUSE:Package Hub 15 SP1","openSUSE:Leap 15.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2020-14147","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","suse:linux_enterprise"],"type":"integer_overflow","year":"2020"},"n_packages":3,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-14148"},"packages":[{"ecosystem":"SUSE:Package Hub 12","fixed":["4.0.14-bp151.3.6.1"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:rpm/suse/redis\u0026distro=SUSE%20Package%20Hub%2012","source":"openSUSE-SU-2020:1035-1"},{"ecosystem":"SUSE:Package Hub 15 SP1","fixed":["4.0.14-bp151.3.6.1"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:rpm/suse/redis\u0026distro=SUSE%20Package%20Hub%2015%20SP1","source":"openSUSE-SU-2020:1035-1"},{"ecosystem":"openSUSE:Leap 15.1","fixed":["4.0.14-bp151.3.6.1"],"introduced":["0"],"last_affected":[],"package":"redis","purl":"pkg:rpm/opensuse/redis\u0026distro=openSUSE%20Leap%2015.1","source":"openSUSE-SU-2020:1035-1"}],"prev":{"headline":"KumbiaPHP Cross-site Scripting","id":"CVE-2020-14146"},"products":["n/a"],"published":"2020-06-15","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers with Lua execution permissions can cause denial of service or bypass sandbox restrictions via integer overflow in Redis.","url":"https://insights.sbomify.com/CVE-2020-14147/"}