# CVE-2020-14188: gajira-create GitHub action vulnerable to arbitrary code execution

> Remote attackers can execute arbitrary code on GitHub runners via crafted issues in the Atlassian gajira-create action.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4xqx-pqpj-9fqw

## What is CVE-2020-14188?

CVE-2020-14188 is a critical code injection vulnerability in Atlassian gajira-create, published on 9 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The preprocessArgs function in the Atlassian gajira-create GitHub Action before version 2.0.1 allows remote attackers to execute arbitrary code in the context of a GitHub runner by creating a specially crafted GitHub issue.

## Which versions are affected by CVE-2020-14188?

1 open source package ship an affected version, including atlassian/gajira-create. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `atlassian/gajira-create` | GitHub Actions | All versions | 2.0.1 |

Products: Atlassian Jira Create.

## How do I fix CVE-2020-14188?

Upgrade atlassian/gajira-create to 2.0.1 or later.

## Is CVE-2020-14188 being exploited?

There is no known exploitation of CVE-2020-14188 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14188 and fix it if it is affected.

What it is: CVE-2020-14188 is a critical code injection vulnerability in Atlassian gajira-create, published on 9 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14188 in the wild and no public exploit code.

Affected packages and fixed versions:
- atlassian/gajira-create (GitHub Actions): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14188/ (Markdown: https://insights.sbomify.com/CVE-2020-14188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14188
- OSV: https://osv.dev/vulnerability/CVE-2020-14188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14188/
Summaries are generated and may contain mistakes; the official description above is the record.
