CVE-2020-14208 Cross-site scripting in n/a

Medium 5.4 Published Updated

Remote authenticated attackers can inject arbitrary web script or HTML via the Documents preview functionality in SuiteCRM.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-14208?

CVE-2020-14208 is a medium-severity cross-site scripting vulnerability in Salesagility Suitecrm, published on 18 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

SuiteCRM 7.11.13 is affected by stored Cross-Site Scripting (XSS) in the Documents preview functionality. This vulnerability could allow remote authenticated attackers to inject arbitrary web script or HTML.

Weakness: CWE-79

Which versions are affected by CVE-2020-14208?

1 open source package ship an affected version, including suitecrm. It affects 1 product.

PackageAffectedFixed in
suitecrm BitnamiAll versions7.11.14

Products include Salesagility Suitecrm.

How do I fix CVE-2020-14208?

Upgrade suitecrm to 7.11.14 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-14208 being exploited?

There is no known exploitation of CVE-2020-14208 in the wild and no public exploit code.

All Salesagility Suitecrm vulnerabilities

Sources

Also known as BIT-suitecrm-2020-14208, GHSA-3769-65j8-fv22.

Is CVE-2020-14208 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free