CVE-2020-14316 Privilege Escalation in kubevirt

Critical 9.9 Published Updated

Attackers can exploit KubeVirt VMIs to access the host filesystem, read or modify files, and escalate privileges to the host process level.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-14316?

CVE-2020-14316 is a critical path traversal vulnerability in kubevirt, published on 29 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A flaw was found in kubevirt 0.29 and earlier. Virtual Machine Instances (VMIs) can be used to gain access to the host's filesystem. Successful exploitation allows an attacker to assume the privileges of the VM process on the host system. In worst-case scenarios an attacker can read and modify any file on the system where the VMI is running. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Which versions are affected by CVE-2020-14316?

3 open source packages ship an affected version, including kubevirt.io/kubevirt. It affects 2 products.

PackageAffectedFixed in
kubevirt.io/kubevirt GoAll versions0.30.0
kubevirt.io/kubevirt GoAll versions0.30.0
kubevirt.io/kubevirt GoAll versions0.30.0

Products include Kubevirt Kubevirt, Redhat Openshift Virtualization.

How do I fix CVE-2020-14316?

Upgrade kubevirt.io/kubevirt to 0.30.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2020-14316 being exploited?

There is no known exploitation of CVE-2020-14316 in the wild and no public exploit code.

Sources

Also known as GHSA-828r-r2c8-rfw3, GO-2024-2756.

Is CVE-2020-14316 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free