CVE-2020-14320 Moodle reflected XSS Vulnerability
Reflected XSS in Moodle admin task log allows attackers to execute scripts in victim browsers, potentially leading to session hijacking or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-14320?
CVE-2020-14320 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Moodle before 3.9.1, 3.8.4 and 3.7.7, the filter in the admin task log required extra sanitizing to prevent a reflected XSS risk.
Weakness: CWE-79
Which versions are affected by CVE-2020-14320?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.7 | 3.7.7 |
moodle/moodle Packagist | From 3.7 | 3.7.7 |
moodle/moodle Packagist | From 3.8 | 3.8.4 |
moodle/moodle Packagist | From 3.8 | 3.8.4 |
moodle/moodle Packagist | From 3.9 | 3.9.1 |
moodle/moodle Packagist | From 3.9 | 3.9.1 |
1 more packages
moodle Bitnami | From 3.7.0 | 3.7.7, 3.8.4, 3.9.1 |
Products include Moodle Moodle.
How do I fix CVE-2020-14320?
Upgrade moodle/moodle to a fixed version for your release line: 3.7.7, 3.8.4 or 3.9.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-14320 being exploited?
There is no known exploitation of CVE-2020-14320 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2020-14320, GHSA-fcpw-vqh5-6qwj, UBUNTU-CVE-2020-14320.