CVE-2020-14321 Moodle Incorrect Authorization vulnerability
Teachers can improperly assign themselves the manager role in a course, allowing unauthorized privilege escalation within the Moodle learning platform.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-14321?
CVE-2020-14321 is a high-severity vulnerability in Moodle Moodle, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.
Weakness: CWE-863
Which versions are affected by CVE-2020-14321?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.5.13 |
moodle/moodle Packagist | All versions | 3.5.13 |
moodle/moodle Packagist | From 3.6.0-beta | 3.7.7 |
moodle/moodle Packagist | From 3.6.0-beta | 3.7.7 |
moodle/moodle Packagist | From 3.8.0-beta | 3.8.4 |
moodle/moodle Packagist | From 3.8.0-beta | 3.8.4 |
3 more packages
moodle/moodle Packagist | From 3.9.0-beta | 3.9.1 |
moodle/moodle Packagist | From 3.9.0-beta | 3.9.1 |
moodle Bitnami | From 3.5.0 | 3.5.13, 3.7.7, 3.8.4, 3.9.1 |
Products include Moodle Moodle.
How do I fix CVE-2020-14321?
Upgrade moodle/moodle to a fixed version for your release line: 3.5.13, 3.7.7, 3.8.4 or 3.9.1.
Is CVE-2020-14321 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-14321 exists.
Public exploit code: 1 Metasploit module and 3 proofs of concept on GitHub.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2020-14321, GHSA-9q29-jcjw-fw7h, UBUNTU-CVE-2020-14321.