# CVE-2020-14321: Moodle Incorrect Authorization vulnerability

> Teachers can improperly assign themselves the manager role in a course, allowing unauthorized privilege escalation within the Moodle learning platform.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-moodle-2020-14321, GHSA-9q29-jcjw-fw7h, UBUNTU-CVE-2020-14321

## What is CVE-2020-14321?

CVE-2020-14321 is a high-severity vulnerability in Moodle Moodle, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, teachers of a course were able to assign themselves the manager role within that course.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-14321?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 3.5.13 |
| `moodle/moodle` | Packagist | All versions | 3.5.13 |
| `moodle/moodle` | Packagist | From 3.6.0-beta | 3.7.7 |
| `moodle/moodle` | Packagist | From 3.6.0-beta | 3.7.7 |
| `moodle/moodle` | Packagist | From 3.8.0-beta | 3.8.4 |
| `moodle/moodle` | Packagist | From 3.8.0-beta | 3.8.4 |
| `moodle/moodle` | Packagist | From 3.9.0-beta | 3.9.1 |
| `moodle/moodle` | Packagist | From 3.9.0-beta | 3.9.1 |
| `moodle` | Bitnami | From 3.5.0 | 3.5.13, 3.7.7, 3.8.4, 3.9.1 |

Products: Moodle Moodle.

## How do I fix CVE-2020-14321?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.13, 3.7.7, 3.8.4 or 3.9.1.

## Is CVE-2020-14321 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-14321 exists.

Public exploit code:

- Course enrolments allowed privilege escalation from teacher role into manager role to RCE (github_poc): https://github.com/HoangKien1020/CVE-2020-14321
- Python script to exploit CVE-2020-14321 - Moodle 3.9 - Course enrollments allowed privilege escalation from teacher role into manager role to RCE. (github_poc): https://github.com/lanzt/CVE-2020-14321
- Modified Moodle exploit for privilege escalation (Dorvack) (github_poc): https://github.com/f0ns1/CVE-2020-14321-modified-exploit
- Moodle Teacher Enrollment Privilege Escalation to RCE (metasploit)

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14321 and fix it if it is affected.

What it is: CVE-2020-14321 is a high-severity vulnerability in Moodle Moodle, published on 16 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-14321 exists.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 3.5.13
- moodle/moodle (Packagist): affected all versions; fixed in 3.5.13
- moodle/moodle (Packagist): affected from 3.6.0-beta; fixed in 3.7.7
- moodle/moodle (Packagist): affected from 3.6.0-beta; fixed in 3.7.7
- moodle/moodle (Packagist): affected from 3.8.0-beta; fixed in 3.8.4
- moodle/moodle (Packagist): affected from 3.8.0-beta; fixed in 3.8.4
- moodle/moodle (Packagist): affected from 3.9.0-beta; fixed in 3.9.1
- moodle/moodle (Packagist): affected from 3.9.0-beta; fixed in 3.9.1
- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.13, 3.7.7, 3.8.4, 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14321/ (Markdown: https://insights.sbomify.com/CVE-2020-14321/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14321
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14321
- OSV: https://osv.dev/vulnerability/CVE-2020-14321

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14321/
Summaries are generated and may contain mistakes; the official description above is the record.
