CVE-2020-14322 Denial of service in Moodle
Attackers can cause denial of service in Moodle by exploiting unbounded file loading in yui_combo, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-14322?
CVE-2020-14322 is a high-severity denial of service vulnerability in Moodle Moodle, published on 16 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Moodle before 3.9.1, 3.8.4, 3.7.7 and 3.5.13, yui_combo needed to limit the amount of files it can load to help mitigate the risk of denial of service.
Weakness: CWE-770
Which versions are affected by CVE-2020-14322?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | From 3.5.0 | 3.5.13, 3.7.7, 3.8.4, 3.9.1 |
Products include Moodle Moodle.
How do I fix CVE-2020-14322?
Upgrade moodle to a fixed version for your release line: 3.5.13, 3.7.7, 3.8.4 or 3.9.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-14322 being exploited?
There is no known exploitation of CVE-2020-14322 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2020-14322, GHSA-g9qp-5vrr-hh2c, UBUNTU-CVE-2020-14322.