# CVE-2020-14330: Improper Output Neutralization and Improper Encoding or Escaping of Output for Logs in ansible

> Attackers can read sensitive keys from Ansible logs due to improper output neutralization in the uri module, compromising data confidentiality.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-14330, DEBIAN-CVE-2020-14330, GHSA-785x-qw4v-6872, PYSEC-2020-3, UBUNTU-CVE-2020-14330

## What is CVE-2020-14330?

CVE-2020-14330 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An Improper Output Neutralization for Logs flaw was found in Ansible when using the uri module, where sensitive data is exposed to content and json output. This flaw allows an attacker to access the logs or outputs of performed tasks to read keys used in playbooks from other users within the uri module. The highest threat from this vulnerability is to data confidentiality.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2020-14330?

3 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.10.0 |
| `ansible` | PyPI | All versions | 2.10.0 |
| `ansible` | PyPI | All versions | 2.10.0 |

Products: Debian Debian Linux, Redhat Ansible Engine.

## How do I fix CVE-2020-14330?

Upgrade ansible to 2.10.0 or later.

## Is CVE-2020-14330 being exploited?

There is no known exploitation of CVE-2020-14330 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14330 and fix it if it is affected.

What it is: CVE-2020-14330 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-14330 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.10.0
- ansible (PyPI): affected all versions; fixed in 2.10.0
- ansible (PyPI): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14330/ (Markdown: https://insights.sbomify.com/CVE-2020-14330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14330
- OSV: https://osv.dev/vulnerability/CVE-2020-14330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14330/
Summaries are generated and may contain mistakes; the official description above is the record.
