# CVE-2020-14338: Improper Input Validation in Xerces

> A flaw in Wildfly's Xerces XML validation allows crafted XML files to manipulate the validation process, requiring an upgrade to fix.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2026-WN90580, CLSA-2026-1775089631, GHSA-w4jq-qh47-hvjq

## What is CVE-2020-14338?

CVE-2020-14338 is a medium-severity vulnerability in Wildfly, published on 17 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Wildfly's implementation of Xerces, specifically in the way the XMLSchemaValidator class in the JAXP component of Wildfly enforced the "use-grammar-pool-only" feature. This flaw allows a specially-crafted XML file to manipulate the validation process in certain cases. This issue is the same flaw as CVE-2020-14621, which affected OpenJDK, and uses a similar code. This flaw affects all Xerces JBoss versions before 2.12.0.SP3.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-14338?

2 open source packages ship an affected version, including xerces:xercesImpl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xerces:xercesImpl` | Maven | All versions | 2.12.0.sp3 |
| `xerces:xercesImpl` | Maven | All versions | 2.12.0.sp3 |

Products: Redhat Xerces.

## How do I fix CVE-2020-14338?

Upgrade xerces:xercesImpl to 2.12.0.sp3 or later.

## Is CVE-2020-14338 being exploited?

There is no known exploitation of CVE-2020-14338 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14338 and fix it if it is affected.

What it is: CVE-2020-14338 is a medium-severity vulnerability in Wildfly, published on 17 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14338 in the wild and no public exploit code.

Affected packages and fixed versions:
- xerces:xercesImpl (Maven): affected all versions; fixed in 2.12.0.sp3
- xerces:xercesImpl (Maven): affected all versions; fixed in 2.12.0.sp3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14338/ (Markdown: https://insights.sbomify.com/CVE-2020-14338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14338
- OSV: https://osv.dev/vulnerability/CVE-2020-14338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14338/
Summaries are generated and may contain mistakes; the official description above is the record.
