{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-14349 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 10.14.0, 11.9.0 or 12.4.0.","what":"CVE-2020-14349 is a high-severity SQL injection vulnerability in Opensuse Leap, published on 24 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-14349 and fix it if it is affected.\n\nWhat it is: CVE-2020-14349 is a high-severity SQL injection vulnerability in Opensuse Leap, published on 24 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-14349 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 10.0.0; fixed in 10.14.0, 11.9.0, 12.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-14349/ (Markdown: https://insights.sbomify.com/CVE-2020-14349/index.md)","id":"CVE-2020-14349","markdown":"https://insights.sbomify.com/CVE-2020-14349/index.md","name":"CVE-2020-14349","record":{"aliases":["ALPINE-CVE-2020-14349","BIT-postgresql-2020-14349","CLEANSTART-2026-EG52606","GHSA-2783-h34h-q54q","JLSEC-2026-24","UBUNTU-CVE-2020-14349"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"An authenticated attacker can execute arbitrary SQL commands during logical replication due to improper search_path sanitization in PostgreSQL.","user_interaction":"required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":7.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-427","name":"Uncontrolled Search Path Element"}],"description":"It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly sanitize the search_path during logical replication. An authenticated attacker could use this flaw in an attack similar to CVE-2018-1058, in order to execute arbitrary SQL command in the context of the user used for replication.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL injection in PostgreSQL","id":"CVE-2020-14349","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"opensuse:leap","products":["opensuse:leap","postgresql:postgresql"],"type":"sql_injection","year":"2020"},"n_packages":1,"n_references":9,"next":{"headline":"Untrusted Search Path in PostgreSQL","id":"CVE-2020-14350"},"packages":[{"ecosystem":"Bitnami","fixed":["10.14.0","11.9.0","12.4.0"],"introduced":["10.0.0","11.0.0","12.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2020-14349"}],"prev":{"headline":"Denial of service in AMQ","id":"CVE-2020-14348"},"products":["PostgreSQL"],"published":"2020-08-24","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An authenticated attacker can execute arbitrary SQL commands during logical replication due to improper search_path sanitization in PostgreSQL.","url":"https://insights.sbomify.com/CVE-2020-14349/"}