{"answers":{"affected":"2 open source packages ship an affected version, including postgresql and org.postgresql:postgresql. It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-14350 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 9.5.23, 9.6.19, 10.14.0 or 11.9.0.","what":"CVE-2020-14350 is a high-severity code injection vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-14350 and fix it if it is affected.\n\nWhat it is: CVE-2020-14350 is a high-severity code injection vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-14350 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 9.5.0; fixed in 9.5.23, 9.6.19, 10.14.0, 11.9.0, 12.4.0\n- org.postgresql:postgresql (Maven): affected all versions; fixed in 12.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-14350/ (Markdown: https://insights.sbomify.com/CVE-2020-14350/index.md)","id":"CVE-2020-14350","markdown":"https://insights.sbomify.com/CVE-2020-14350/index.md","name":"CVE-2020-14350","record":{"aliases":["ALPINE-CVE-2020-14350","BIT-postgresql-2020-14350","CLEANSTART-2026-TS16733","DLA-2331-1","GHSA-6v9v-3f4c-cjgx","JLSEC-2026-25","UBUNTU-CVE-2020-14350"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code with administrator privileges by exploiting unsafe search_path usage in PostgreSQL extension installation scripts.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"leap","vendor":"opensuse"},{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":7.3,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"It was found that some PostgreSQL extensions did not use search_path safely in their installation script. An attacker with sufficient privileges could use this flaw to trick an administrator into executing a specially crafted script, during the installation or update of such extension. This affects PostgreSQL versions before 12.4, before 11.9, before 10.14, before 9.6.19, and before 9.5.23.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Untrusted Search Path in PostgreSQL","id":"CVE-2020-14350","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","opensuse:leap","postgresql:postgresql"],"type":"code_injection","year":"2020"},"n_packages":2,"n_references":11,"next":{"headline":"Use after free in kernel","id":"CVE-2020-14351"},"packages":[{"ecosystem":"Bitnami","fixed":["9.5.23","9.6.19","10.14.0","11.9.0","12.4.0"],"introduced":["9.5.0","9.6.0","10.0.0","11.0.0","12.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2020-14350"},{"ecosystem":"Maven","fixed":["12.4"],"introduced":["0"],"last_affected":[],"package":"org.postgresql:postgresql","purl":"pkg:maven/org.postgresql/postgresql","source":"GHSA-6v9v-3f4c-cjgx"}],"prev":{"headline":"SQL injection in PostgreSQL","id":"CVE-2020-14349"},"products":["PostgreSQL"],"published":"2020-08-24","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code with administrator privileges by exploiting unsafe search_path usage in PostgreSQL extension installation scripts.","url":"https://insights.sbomify.com/CVE-2020-14350/"}