# CVE-2020-14350: Untrusted Search Path in PostgreSQL

> Attackers can execute arbitrary code with administrator privileges by exploiting unsafe search_path usage in PostgreSQL extension installation scripts.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-14350, BIT-postgresql-2020-14350, CLEANSTART-2026-TS16733, DLA-2331-1, GHSA-6v9v-3f4c-cjgx, JLSEC-2026-25, UBUNTU-CVE-2020-14350

## What is CVE-2020-14350?

CVE-2020-14350 is a high-severity code injection vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

It was found that some PostgreSQL extensions did not use search_path safely in their installation script. An attacker with sufficient privileges could use this flaw to trick an administrator into executing a specially crafted script, during the installation or update of such extension. This affects PostgreSQL versions before 12.4, before 11.9, before 10.14, before 9.6.19, and before 9.5.23.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2020-14350?

2 open source packages ship an affected version, including postgresql and org.postgresql:postgresql. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 9.5.0 | 9.5.23, 9.6.19, 10.14.0, 11.9.0, 12.4.0 |
| `org.postgresql:postgresql` | Maven | All versions | 12.4 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Opensuse Leap, Postgresql Postgresql.

## How do I fix CVE-2020-14350?

Upgrade postgresql to a fixed version for your release line: 9.5.23, 9.6.19, 10.14.0 or 11.9.0.

## Is CVE-2020-14350 being exploited?

There is no known exploitation of CVE-2020-14350 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14350 and fix it if it is affected.

What it is: CVE-2020-14350 is a high-severity code injection vulnerability in Canonical Ubuntu Linux, published on 24 Aug 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-14350 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 9.5.0; fixed in 9.5.23, 9.6.19, 10.14.0, 11.9.0, 12.4.0
- org.postgresql:postgresql (Maven): affected all versions; fixed in 12.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14350/ (Markdown: https://insights.sbomify.com/CVE-2020-14350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14350
- OSV: https://osv.dev/vulnerability/CVE-2020-14350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14350/
Summaries are generated and may contain mistakes; the official description above is the record.
