CVE-2020-14365 Improper Verification of Cryptographic Signature in ansible

High 7.1 Published Updated

Ansible ignores GPG checks during DNF package installation, allowing attackers to install malicious packages and execute arbitrary code.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2020-14365?

CVE-2020-14365 is a high-severity vulnerability in Debian Debian Linux, published on 23 Sep 2020. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module. GPG signatures are ignored during installation even when disable_gpg_check is set to False, which is the default behavior. This flaw leads to malicious packages being installed on the system and arbitrary code executed via package installation scripts. The highest threat from this vulnerability is to integrity and system availability.

Weakness: CWE-347

Which versions are affected by CVE-2020-14365?

5 open source packages ship an affected version, including ansible. It affects 5 products.

PackageAffectedFixed in
ansible PyPIFrom 2.8.02.8.16rc1, 2.9.14rc1
ansible PyPIFrom 2.8.0a12.8.15
ansible PyPIFrom 2.8.0a12.8.15
ansible PyPIFrom 2.9.0a12.9.13
ansible PyPIFrom 2.9.0a12.9.13
Linux distribution packages (8)
ansible Red Hat:ansible_engine:2.9::el7All versions0:2.9.13-1.el7ae
ansible-test Red Hat:ansible_engine:2.9::el7All versions0:2.9.13-1.el7ae
ansible Red Hat:ansible_engine:2.9::el8All versions0:2.9.13-1.el8ae
ansible-test Red Hat:ansible_engine:2.9::el8All versions0:2.9.13-1.el8ae
ansible Red Hat:ansible_engine:2::el7All versions0:2.9.13-1.el7ae
ansible-test Red Hat:ansible_engine:2::el7All versions0:2.9.13-1.el7ae
ansible Red Hat:ansible_engine:2::el8All versions0:2.9.13-1.el8ae
ansible-test Red Hat:ansible_engine:2::el8All versions0:2.9.13-1.el8ae

Products include Debian Debian Linux, Redhat Ansible Engine, Redhat Ansible Tower, Redhat Ceph Storage, Redhat Openstack Platform.

How do I fix CVE-2020-14365?

Upgrade ansible to a fixed version for your release line: 2.8.16rc1, 2.9.14rc1, 2.8.15 or 2.9.13.

Is CVE-2020-14365 being exploited?

There is no known exploitation of CVE-2020-14365 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2020-14365, DEBIAN-CVE-2020-14365, GHSA-m429-fhmv-c6q2, PYSEC-2020-209, RHSA-2020:3601, RHSA-2020:3602 and 1 more.

Is CVE-2020-14365 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free