# CVE-2020-14365: Improper Verification of Cryptographic Signature in ansible

> Ansible ignores GPG checks during DNF package installation, allowing attackers to install malicious packages and execute arbitrary code.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-14365, DEBIAN-CVE-2020-14365, GHSA-m429-fhmv-c6q2, PYSEC-2020-209, RHSA-2020:3601, RHSA-2020:3602, UBUNTU-CVE-2020-14365

## What is CVE-2020-14365?

CVE-2020-14365 is a high-severity vulnerability in Debian Debian Linux, published on 23 Sep 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module. GPG signatures are ignored during installation even when disable_gpg_check is set to False, which is the default behavior. This flaw leads to malicious packages being installed on the system and arbitrary code executed via package installation scripts. The highest threat from this vulnerability is to integrity and system availability.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2020-14365?

5 open source packages ship an affected version, including ansible. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.8.0 | 2.8.16rc1, 2.9.14rc1 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.15 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.15 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.13 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.13 |
| `ansible` | Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.13-1.el7ae |
| `ansible-test` | Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.13-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.13-1.el8ae |
| `ansible-test` | Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.13-1.el8ae |
| `ansible` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.13-1.el7ae |
| `ansible-test` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.13-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.13-1.el8ae |
| `ansible-test` | Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.13-1.el8ae |

Products: Debian Debian Linux, Redhat Ansible Engine, Redhat Ansible Tower, Redhat Ceph Storage, Redhat Openstack Platform.

## How do I fix CVE-2020-14365?

Upgrade ansible to a fixed version for your release line: 2.8.16rc1, 2.9.14rc1, 2.8.15 or 2.9.13.

## Is CVE-2020-14365 being exploited?

There is no known exploitation of CVE-2020-14365 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14365 and fix it if it is affected.

What it is: CVE-2020-14365 is a high-severity vulnerability in Debian Debian Linux, published on 23 Sep 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14365 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.8.0; fixed in 2.8.16rc1, 2.9.14rc1
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.15
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.15
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.13
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14365/ (Markdown: https://insights.sbomify.com/CVE-2020-14365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14365
- OSV: https://osv.dev/vulnerability/CVE-2020-14365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14365/
Summaries are generated and may contain mistakes; the official description above is the record.
