CVE-2020-14460 Missing authorization in n/a
Attackers can create trusted OAuth applications without admin privileges, potentially leading to unauthorized access or privilege escalation in Mattermost Server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-14460?
CVE-2020-14460 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Mattermost Server before 5.19.0, 5.18.1, 5.17.3, 5.16.5, and 5.9.8. Creation of a trusted OAuth application does not always require admin privileges, aka MMSA-2020-0001.
Which versions are affected by CVE-2020-14460?
1 open source package ship an affected version, including mattermost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mattermost Bitnami | All versions to 5.19.0-rc1 | 5.9.8, 5.16.5, 5.17.3, 5.18.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2020-14460?
Upgrade mattermost to a fixed version for your release line: 5.9.8, 5.16.5, 5.17.3 or 5.18.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-14460 being exploited?
There is no known exploitation of CVE-2020-14460 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2020-14460, GHSA-q3mp-8r6g-jvm4.