CVE-2020-14550 Denial of service in MySQL Server
A low-privileged attacker can cause a complete denial of service in the MySQL Client via network access.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-14550?
CVE-2020-14550 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.6.48 and prior, 5.7.30 and prior and 8.0.20 and prior. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Client. CVSS 3.1 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H).
Which versions are affected by CVE-2020-14550?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 7 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 5.5.0 | 5.5.61, 10.0.35, 10.1.33, 10.2.15 |
mariadb-min Bitnami | From 5.5.0 | 5.5.61, 10.0.35, 10.1.33, 10.2.15 |
mysql-client Bitnami | From 5.5.0 | 5.5.61, 10.0.35, 10.1.33, 10.2.15 |
Products include Canonical Ubuntu Linux, Fedoraproject Fedora, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation and 1 more.
How do I fix CVE-2020-14550?
Upgrade mariadb to a fixed version for your release line: 5.5.61, 10.0.35, 10.1.33 or 10.2.15.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-14550 being exploited?
There is no known exploitation of CVE-2020-14550 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-mariadb-2020-14550, BIT-mariadb-min-2020-14550, BIT-mysql-client-2020-14550, GHSA-mg2j-853w-r6h2, UBUNTU-CVE-2020-14550.