CVE-2020-14621 Other in Java
An unauthenticated attacker can modify data in Java SE via JAXP APIs, requiring a patch to prevent unauthorized integrity violations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-14621?
CVE-2020-14621 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 15 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: JAXP). Supported versions that are affected are Java SE: 7u261, 8u251, 11.0.7 and 14.0.1; Java SE Embedded: 8u251. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE, Java SE Embedded accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N).
Which versions are affected by CVE-2020-14621?
3 open source packages ship an affected version, including java, java-min and jre. It affects 23 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2 |
java-min Bitnami | All versions | 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2 |
jre Bitnami | All versions | 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Mcafee Epolicy Orchestrator, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager and 17 more.
How do I fix CVE-2020-14621?
Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.271 or 8.0.261.
Is CVE-2020-14621 being exploited?
There is no known exploitation of CVE-2020-14621 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as BIT-java-2020-14621, BIT-java-min-2020-14621, BIT-jre-2020-14621, CLEANSTART-2026-MK68807, CLEANSTART-2026-WK43014, DEBIAN-CVE-2020-14621 and 7 more.