# CVE-2020-14621: Other in Java

> An unauthenticated attacker can modify data in Java SE via JAXP APIs, requiring a patch to prevent unauthorized integrity violations.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2020
- **Updated:** 27 Sep 2024
- **Also known as:** BIT-java-2020-14621, BIT-java-min-2020-14621, BIT-jre-2020-14621, CLEANSTART-2026-MK68807, CLEANSTART-2026-WK43014, DEBIAN-CVE-2020-14621, GHSA-p493-cq87-mf78, MINI-fgq5-82cj-vf48, MINI-mgrr-6ggh-5vr6, MINI-v9gv-q7jp-hpm6, MINI-wwp2-hhv7-c6v2, MINI-x2w9-5gqp-vv9c, UBUNTU-CVE-2020-14621

## What is CVE-2020-14621?

CVE-2020-14621 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 15 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: JAXP). Supported versions that are affected are Java SE: 7u261, 8u251, 11.0.7 and 14.0.1; Java SE Embedded: 8u251. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE, Java SE Embedded accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N).

## Which versions are affected by CVE-2020-14621?

3 open source packages ship an affected version, including java, java-min and jre. It affects 23 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2 |
| `java-min` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2 |
| `jre` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Mcafee Epolicy Orchestrator, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager, Netapp Cloud Backup, Netapp Cloud Secure Agent, Netapp E-Series Performance Analyzer, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Storage Manager, Netapp E-Series Santricity Web Services, Netapp Oncommand Insight, Netapp Oncommand Unified Manager Core Package, Netapp Oncommand Workflow Automation, Netapp Plug-in for Symantec Netbackup, Netapp Santricity Unified Manager, Netapp Snapmanager, Netapp Steelstore Cloud Integrated Storage, Opensuse Leap and 3 more.

## How do I fix CVE-2020-14621?

Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.271 or 8.0.261.

## Is CVE-2020-14621 being exploited?

There is no known exploitation of CVE-2020-14621 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14621 and fix it if it is affected.

What it is: CVE-2020-14621 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 15 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14621 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2
- java-min (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2
- jre (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.271, 8.0.261, 11.0.8, 14.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14621/ (Markdown: https://insights.sbomify.com/CVE-2020-14621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14621
- OSV: https://osv.dev/vulnerability/CVE-2020-14621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14621/
Summaries are generated and may contain mistakes; the official description above is the record.
