CVE-2020-14765 Denial of service in MySQL Server
A low-privileged attacker can cause a complete denial of service in MySQL Server via the Full-Text Search component.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-14765?
CVE-2020-14765 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 21 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: FTS). Supported versions that are affected are 5.6.49 and prior, 5.7.31 and prior and 8.0.21 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).
Which versions are affected by CVE-2020-14765?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.1.0 | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |
mariadb-min Bitnami | From 10.1.0 | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |
mysql-client Bitnami | From 10.1.0 | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation and 2 more.
How do I fix CVE-2020-14765?
Upgrade mariadb to a fixed version for your release line: 10.1.48, 10.2.35, 10.3.26 or 10.4.16.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-14765 being exploited?
There is no known exploitation of CVE-2020-14765 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2020-14765, BIT-mariadb-2020-14765, BIT-mariadb-min-2020-14765, BIT-mysql-client-2020-14765, DEBIAN-CVE-2020-14765, GHSA-386x-hp87-5862 and 1 more.