# CVE-2020-14782: Other in Java SE JDK and JRE

> An unauthenticated attacker can modify Java SE data via network access, requiring a patch to mitigate integrity risks.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2020
- **Updated:** 26 Sep 2024
- **Also known as:** BIT-java-2020-14782, BIT-java-min-2020-14782, BIT-jre-2020-14782, CLEANSTART-2026-GB50423, CLEANSTART-2026-IA33324, DEBIAN-CVE-2020-14782, GHSA-2r7j-vm47-9h8m, MINI-59j6-xqj4-2897, MINI-8j85-3mgr-qwc6, MINI-crp6-wmfj-jqqf, MINI-fr96-652m-w9j2, MINI-qj66-4rm8-q7pf, MINI-rvcw-cwxw-v4m9, UBUNTU-CVE-2020-14782

## What is CVE-2020-14782?

CVE-2020-14782 is a low-severity vulnerability in Debian Debian Linux, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u271, 8u261, 11.0.8 and 15; Java SE Embedded: 8u261. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE, Java SE Embedded accessible data. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.1 Base Score 3.7 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N).

## Which versions are affected by CVE-2020-14782?

3 open source packages ship an affected version, including java, java-min and jre. It affects 16 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1 |
| `java-min` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1 |
| `jre` | Bitnami | All versions | 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1 |

Products: Debian Debian Linux, Mcafee Epolicy Orchestrator, Netapp Active Iq Unified Manager, Netapp E-Series Performance Analyzer, Netapp E-Series Santricity Management Plug-Ins, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Storage Manager, Netapp E-Series Santricity Web Services Proxy, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Santricity Unified Manager, Netapp Steelstore Cloud Integrated Storage, Opensuse Leap, Oracle Jdk, Oracle Jre, Oracle Openjdk.

## How do I fix CVE-2020-14782?

Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.281 or 8.0.271.

## Is CVE-2020-14782 being exploited?

There is no known exploitation of CVE-2020-14782 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14782 and fix it if it is affected.

What it is: CVE-2020-14782 is a low-severity vulnerability in Debian Debian Linux, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14782 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1
- java-min (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1
- jre (Bitnami): affected all versions; fixed in 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14782/ (Markdown: https://insights.sbomify.com/CVE-2020-14782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14782
- OSV: https://osv.dev/vulnerability/CVE-2020-14782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14782/
Summaries are generated and may contain mistakes; the official description above is the record.
