CVE-2020-14792 Other in Java SE JDK and JRE
An unauthenticated attacker can read and modify limited Java SE data via network access, requiring user interaction.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-14792?
CVE-2020-14792 is a medium-severity vulnerability in Debian Debian Linux, published on 21 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Java SE: 7u271, 8u261, 11.0.8 and 15; Java SE Embedded: 8u261. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Java SE, Java SE Embedded accessible data as well as unauthorized read access to a subset of Java SE, Java SE Embedded accessible data. Note: Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.1 Base Score 4.2 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N).
Which versions are affected by CVE-2020-14792?
3 open source packages ship an affected version, including java, java-min and jre. It affects 19 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1 |
java-min Bitnami | All versions | 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1 |
jre Bitnami | All versions | 1.7.0, 1.8.0, 7.0.281, 8.0.271, 11.0.9, 15.0.1 |
Products include Debian Debian Linux, Mcafee Epolicy Orchestrator, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Storage Manager and 13 more.
How do I fix CVE-2020-14792?
Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.281 or 8.0.271.
Is CVE-2020-14792 being exploited?
There is no known exploitation of CVE-2020-14792 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-java-2020-14792, BIT-java-min-2020-14792, BIT-jre-2020-14792, CLEANSTART-2026-HX50745, CLEANSTART-2026-UR22102, DEBIAN-CVE-2020-14792 and 8 more.