# CVE-2020-14812: Denial of service in MySQL Server

> A high-privileged attacker can cause a complete denial of service in MySQL Server by triggering a hang or crash via network access.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2020
- **Updated:** 26 Sep 2024
- **Also known as:** ALPINE-CVE-2020-14812, BIT-mariadb-2020-14812, BIT-mariadb-min-2020-14812, BIT-mysql-client-2020-14812, DEBIAN-CVE-2020-14812, GHSA-9q26-4qw9-g46v, UBUNTU-CVE-2020-14812

## What is CVE-2020-14812?

CVE-2020-14812 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 21 Oct 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Locking). Supported versions that are affected are 5.6.49 and prior, 5.7.31 and prior and 8.0.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

## Which versions are affected by CVE-2020-14812?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.1.0 | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |
| `mariadb-min` | Bitnami | From 10.1.0 | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |
| `mysql-client` | Bitnami | From 10.1.0 | 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7 |

Products: Debian Debian Linux, Fedoraproject Fedora, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Oracle Mysql.

## How do I fix CVE-2020-14812?

Upgrade mariadb to a fixed version for your release line: 10.1.48, 10.2.35, 10.3.26 or 10.4.16.

## Is CVE-2020-14812 being exploited?

There is no known exploitation of CVE-2020-14812 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14812 and fix it if it is affected.

What it is: CVE-2020-14812 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 21 Oct 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14812 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.1.0; fixed in 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7
- mariadb-min (Bitnami): affected from 10.1.0; fixed in 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7
- mysql-client (Bitnami): affected from 10.1.0; fixed in 10.1.48, 10.2.35, 10.3.26, 10.4.16, 10.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14812/ (Markdown: https://insights.sbomify.com/CVE-2020-14812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14812
- OSV: https://osv.dev/vulnerability/CVE-2020-14812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14812/
Summaries are generated and may contain mistakes; the official description above is the record.
