{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-14929 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-14929 is a high-severity vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-14929 and fix it if it is affected.\n\nWhat it is: CVE-2020-14929 is a high-severity vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-14929 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-14929/ (Markdown: https://insights.sbomify.com/CVE-2020-14929/index.md)","id":"CVE-2020-14929","markdown":"https://insights.sbomify.com/CVE-2020-14929/index.md","name":"CVE-2020-14929","record":{"aliases":["CLEANSTART-2024-TQ30021","DEBIAN-CVE-2020-14929","DLA-2254-1","GHSA-2h9h-wfvh-5r96","MGASA-2021-0014","UBUNTU-CVE-2020-14929","openSUSE-SU-2021:0675-1","openSUSE-SU-2021:0695-1","openSUSE-SU-2024:10613-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"IMAP client library","requires_auth":"none","summary":"The Alpine IMAP client library silently continues using an insecure connection after a TLS command failure, bypassing expected security checks.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"alpine","vendor":"alpine_project"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[],"description":"Alpine before 2.23 silently proceeds to use an insecure connection after a /tls is sent in certain circumstances involving PREAUTH, which is a less secure behavior than the alternative of closing the connection and letting the user decide what they would like to do.","ecosystems":["SUSE:Package Hub 15 SP2","openSUSE:Leap 15.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2020-14929","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":4,"next":{"headline":"Information disclosure in n/a","id":"CVE-2020-14930"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP2","fixed":["2.24-bp152.4.3.1"],"introduced":["0"],"last_affected":[],"package":"alpine","purl":"pkg:rpm/suse/alpine\u0026distro=SUSE%20Package%20Hub%2015%20SP2","source":"openSUSE-SU-2021:0695-1"},{"ecosystem":"openSUSE:Leap 15.2","fixed":["2.24-lp152.5.3.1"],"introduced":["0"],"last_affected":[],"package":"alpine","purl":"pkg:rpm/opensuse/alpine\u0026distro=openSUSE%20Leap%2015.2","source":"openSUSE-SU-2021:0675-1"}],"prev":{"headline":"Other in n/a","id":"CVE-2020-14928"},"products":["n/a"],"published":"2020-06-19","related":[{"cvss_score":7.5,"headline":"URL access filters bypass in Alpine","id":"CVE-2022-23553","kev_date_added":null,"published":"2022-12-28"},{"cvss_score":6.5,"headline":"Authentication bypass in Alpine","id":"CVE-2022-23554","kev_date_added":null,"published":"2022-12-28"},{"cvss_score":5.9,"headline":"Race condition in n/a","id":"CVE-2021-46853","kev_date_added":null,"published":"2022-11-03"},{"cvss_score":5.9,"headline":"Security feature bypass in n/a","id":"CVE-2021-38370","kev_date_added":null,"published":"2021-08-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"The Alpine IMAP client library silently continues using an insecure connection after a TLS command failure, bypassing expected security checks.","url":"https://insights.sbomify.com/CVE-2020-14929/"}