# CVE-2020-14942: Deserialization of Untrusted Data in Tendenci

> Attackers can execute arbitrary code via unrestricted deserialization in the Tendenci helpdesk staff view.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jqmc-fxxp-r589, PYSEC-2020-112

## What is CVE-2020-14942?

CVE-2020-14942 is a critical unsafe deserialization vulnerability in n/a, published on 21 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tendenci 12.0.10 allows unrestricted deserialization in apps\helpdesk\views\staff.py.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-14942?

3 open source packages ship an affected version, including tendenci. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tendenci` | PyPI | All versions | 12.0.11 |
| `tendenci` | PyPI | All versions | 12.0.11 |
| `tendenci` | PyPI | All versions | 12.0.11 |

Products: Tendenci Tendenci.

## How do I fix CVE-2020-14942?

Upgrade tendenci to 12.0.11 or later.

## Is CVE-2020-14942 being exploited?

There is no known exploitation of CVE-2020-14942 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-23946](https://insights.sbomify.com/CVE-2026-23946/): Tendenci has Authenticated Remote Code Execution via Pickle Deserialization (medium 6.8)
- [CVE-2025-70959](https://insights.sbomify.com/CVE-2025-70959/): Tendenci CMS Contains a Cross-site Scripting Vulnerability in its Jobs Module (medium 5.4)
- [CVE-2025-70960](https://insights.sbomify.com/CVE-2025-70960/): Tendenci CMS contains a stored Cross-site Scripting (XSS) vulnerability in the Forums module (medium 5.4)
- [CVE-2020-36962](https://insights.sbomify.com/CVE-2020-36962/): Tendenci 12.3.1 - CSV/ Formula Injection (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-14942 and fix it if it is affected.

What it is: CVE-2020-14942 is a critical unsafe deserialization vulnerability in n/a, published on 21 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-14942 in the wild and no public exploit code.

Affected packages and fixed versions:
- tendenci (PyPI): affected all versions; fixed in 12.0.11
- tendenci (PyPI): affected all versions; fixed in 12.0.11
- tendenci (PyPI): affected all versions; fixed in 12.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-14942/ (Markdown: https://insights.sbomify.com/CVE-2020-14942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-14942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-14942
- OSV: https://osv.dev/vulnerability/CVE-2020-14942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-14942/
Summaries are generated and may contain mistakes; the official description above is the record.
