CVE-2020-15005 img_auth.php may leak private extension images into the public cache
Private MediaWiki files may be cached publicly by caching servers due to mishandled headers, allowing unauthorized users to view them.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15005?
CVE-2020-15005 is a low-severity vulnerability in Debian Debian Linux, published on 24 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In MediaWiki before 1.31.8, 1.32.x and 1.33.x before 1.33.4, and 1.34.x before 1.34.2, private wikis behind a caching server using the img_auth.php image authorization security feature may have had their files cached publicly, so any unauthorized user could view them. This occurs because Cache-Control and Vary headers were mishandled.
Which versions are affected by CVE-2020-15005?
7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | All versions | 1.31.8 |
mediawiki/core Packagist | All versions | 1.31.8 |
mediawiki/core Packagist | From 1.32.0 | 1.33.4 |
mediawiki/core Packagist | From 1.32.0 | 1.33.4 |
mediawiki/core Packagist | From 1.34.0 | 1.34.2 |
mediawiki/core Packagist | From 1.34.0 | 1.34.2 |
1 more packages
mediawiki Bitnami | All versions | 1.31.8, 1.33.4, 1.34.2 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2020-15005?
Upgrade mediawiki/core to a fixed version for your release line: 1.31.8, 1.33.4 or 1.34.2.
Is CVE-2020-15005 being exploited?
There is no known exploitation of CVE-2020-15005 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2020-15005, DEBIAN-CVE-2020-15005, GHSA-xpv7-93cm-4mxv, MGASA-2020-0292, UBUNTU-CVE-2020-15005.