# CVE-2020-15005: img_auth.php may leak private extension images into the public cache

> Private MediaWiki files may be cached publicly by caching servers due to mishandled headers, allowing unauthorized users to view them.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2020-15005, DEBIAN-CVE-2020-15005, GHSA-xpv7-93cm-4mxv, MGASA-2020-0292, UBUNTU-CVE-2020-15005

## What is CVE-2020-15005?

CVE-2020-15005 is a low-severity vulnerability in Debian Debian Linux, published on 24 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In MediaWiki before 1.31.8, 1.32.x and 1.33.x before 1.33.4, and 1.34.x before 1.34.2, private wikis behind a caching server using the img_auth.php image authorization security feature may have had their files cached publicly, so any unauthorized user could view them. This occurs because Cache-Control and Vary headers were mishandled.

## Which versions are affected by CVE-2020-15005?

7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | All versions | 1.31.8 |
| `mediawiki/core` | Packagist | All versions | 1.31.8 |
| `mediawiki/core` | Packagist | From 1.32.0 | 1.33.4 |
| `mediawiki/core` | Packagist | From 1.32.0 | 1.33.4 |
| `mediawiki/core` | Packagist | From 1.34.0 | 1.34.2 |
| `mediawiki/core` | Packagist | From 1.34.0 | 1.34.2 |
| `mediawiki` | Bitnami | All versions | 1.31.8, 1.33.4, 1.34.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2020-15005?

Upgrade mediawiki/core to a fixed version for your release line: 1.31.8, 1.33.4 or 1.34.2.

## Is CVE-2020-15005 being exploited?

There is no known exploitation of CVE-2020-15005 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15005 and fix it if it is affected.

What it is: CVE-2020-15005 is a low-severity vulnerability in Debian Debian Linux, published on 24 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15005 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected all versions; fixed in 1.31.8
- mediawiki/core (Packagist): affected all versions; fixed in 1.31.8
- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.33.4
- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.33.4
- mediawiki/core (Packagist): affected from 1.34.0; fixed in 1.34.2
- mediawiki/core (Packagist): affected from 1.34.0; fixed in 1.34.2
- mediawiki (Bitnami): affected all versions; fixed in 1.31.8, 1.33.4, 1.34.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15005/ (Markdown: https://insights.sbomify.com/CVE-2020-15005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15005
- OSV: https://osv.dev/vulnerability/CVE-2020-15005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15005/
Summaries are generated and may contain mistakes; the official description above is the record.
