# CVE-2020-15008: SQL injection in n/a

> Attackers can execute arbitrary SQL commands via the probe code to extract or modify data due to inadequate validation of table names.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cg9h-vhcr-m9qp

## What is CVE-2020-15008?

CVE-2020-15008 is a high-severity SQL injection vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A SQLi exists in the probe code of all Connectwise Automate versions before 2020.7 or 2019.12. A SQL Injection in the probe implementation to save data to a custom table exists due to inadequate server side validation. As the code creates dynamic SQL for the insert statement and utilizes the user supplied table name with little validation, the table name can be modified to allow arbitrary update commands to be run. Usage of other SQL injection techniques such as timing attacks, it is possible to perform full data extraction as well. Patched in 2020.7 and in a hotfix for 2019.12.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-15008?

It affects 1 product.


Products: Connectwise Connectwise Automate.

## How do I fix CVE-2020-15008?

No fix has been published for CVE-2020-15008 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-15008 being exploited?

There is no known exploitation of CVE-2020-15008 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-32582](https://insights.sbomify.com/CVE-2021-32582/): SQL injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15008 and fix it if it is affected.

What it is: CVE-2020-15008 is a high-severity SQL injection vulnerability in n/a, published on 7 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15008 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15008/ (Markdown: https://insights.sbomify.com/CVE-2020-15008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15008
- OSV: https://osv.dev/vulnerability/CVE-2020-15008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15008/
Summaries are generated and may contain mistakes; the official description above is the record.
