# CVE-2020-15072: SQL injection in n/a

> Attackers can perform error-based SQL injection via the Import Administrators section to read or modify database contents.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-phplist-2020-15072, GHSA-x5mc-6q9h-2g4j

## What is CVE-2020-15072?

CVE-2020-15072 is a high-severity SQL injection vulnerability in n/a, published on 8 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in phpList through 3.5.4. An error-based SQL Injection vulnerability exists via the Import Administrators section.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-15072?

1 open source package ship an affected version, including phplist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phplist` | Bitnami | All versions | 3.5.4 |

Products: Phplist Phplist.

## How do I fix CVE-2020-15072?

Upgrade phplist to 3.5.4 or later.

## Is CVE-2020-15072 being exploited?

There is no known exploitation of CVE-2020-15072 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-22249](https://insights.sbomify.com/CVE-2020-22249/): File upload in n/a (critical 9.8)
- [CVE-2020-23361](https://insights.sbomify.com/CVE-2020-23361/): Auth bypass in n/a (critical 9.8)
- [CVE-2021-3188](https://insights.sbomify.com/CVE-2021-3188/): Other in n/a (critical 9.8)
- [CVE-2020-8547](https://insights.sbomify.com/CVE-2020-8547/): Auth bypass in n/a (critical 9.8)
- [CVE-2012-2740](https://insights.sbomify.com/CVE-2012-2740/): SQL injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15072 and fix it if it is affected.

What it is: CVE-2020-15072 is a high-severity SQL injection vulnerability in n/a, published on 8 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15072 in the wild and no public exploit code.

Affected packages and fixed versions:
- phplist (Bitnami): affected all versions; fixed in 3.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15072/ (Markdown: https://insights.sbomify.com/CVE-2020-15072/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15072
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15072
- OSV: https://osv.dev/vulnerability/CVE-2020-15072

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15072/
Summaries are generated and may contain mistakes; the official description above is the record.
