# CVE-2020-15080: Information disclosure in release archive in PrestaShop

> Attackers can access sensitive configuration files like composer.json and docker-compose.yml from the web server, potentially revealing infrastructure details.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-492w-2pp5-xhvg

## What is CVE-2020-15080?

CVE-2020-15080 is a medium-severity vulnerability in Prestashop Prestashop, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PrestaShop from version 1.7.4.0 and before version 1.7.6.6, some files should not be in the release archive, and others should not be accessible. The problem is fixed in version 1.7.6.6 A possible workaround is to make sure `composer.json` and `docker-compose.yml` are not accessible on your server.

Weakness: CWE-862 (Missing Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-15080?

It affects 1 product.


Products: Prestashop Prestashop.

## How do I fix CVE-2020-15080?

No fix has been published for CVE-2020-15080 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-15080 being exploited?

There is no known exploitation of CVE-2020-15080 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15080 and fix it if it is affected.

What it is: CVE-2020-15080 is a medium-severity vulnerability in Prestashop Prestashop, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15080 in the wild and no public exploit code.

Affected product: Prestashop Prestashop. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15080/ (Markdown: https://insights.sbomify.com/CVE-2020-15080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15080
- OSV: https://osv.dev/vulnerability/CVE-2020-15080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15080/
Summaries are generated and may contain mistakes; the official description above is the record.
