CVE-2020-15082 External control of configuration setting in the dashboard in PrestaShop

High 7.1 Published Updated

Attackers can rewrite all configuration variables via the dashboard, potentially compromising site integrity and security settings.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2020-15082?

CVE-2020-15082 is a high-severity vulnerability in Prestashop Prestashop, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In PrestaShop from version 1.6.0.1 and before version 1.7.6.6, the dashboard allows rewriting all configuration variables. The problem is fixed in 1.7.6.6

Which versions are affected by CVE-2020-15082?

It affects 1 product.

Products include Prestashop Prestashop.

How do I fix CVE-2020-15082?

No fix has been published for CVE-2020-15082 yet. Limit exposure of the affected software until one is available.

Is CVE-2020-15082 being exploited?

There is no known exploitation of CVE-2020-15082 in the wild and no public exploit code.

All Prestashop Prestashop vulnerabilities

Sources

Also known as GHSA-mc98-xjm3-c4fm.

Is CVE-2020-15082 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free