{"answers":{"affected":"2 open source packages ship an affected version, including express-jwt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15084 in the wild and no public exploit code.","fix":"Upgrade express-jwt to 6.0.0 or later.","what":"CVE-2020-15084 is a high-severity authentication bypass vulnerability in auth0 express-jwt, published on 30 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15084 and fix it if it is affected.\n\nWhat it is: CVE-2020-15084 is a high-severity authentication bypass vulnerability in auth0 express-jwt, published on 30 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15084 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-jwt (npm): affected all versions; fixed in 6.0.0\n- express-jwt (npm): affected all versions; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15084/ (Markdown: https://insights.sbomify.com/CVE-2020-15084/index.md)","id":"CVE-2020-15084","markdown":"https://insights.sbomify.com/CVE-2020-15084/index.md","name":"CVE-2020-15084","record":{"aliases":["CLSA-2026-1774570939","CLSA-2026-1774570940","GHSA-6g6m-m6h5-w9gf","ROOT-APP-NPM-CVE-2020-15084"],"analysis":{"component_type":"library","fix_type":"configuration_change","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js JWT middleware","requires_auth":"low_privilege","summary":"Attackers can bypass authorization in express-jwt if algorithms are not configured, allowing unauthorized access to protected resources.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"express-jwt","vendor":"auth0"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"In express-jwt (NPM package) up and including version 5.3.3, the algorithms entry to be specified in the configuration is not being enforced. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. You are affected by this vulnerability if all of the following conditions apply: - You are using express-jwt - You do not have **algorithms** configured in your express-jwt configuration. - You are using libraries such as jwks-rsa as the **secret**. You can fix this by specifying **algorithms** in the express-jwt configuration. See linked GHSA for example. This is also fixed in version 6.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authorization bypass in express-jwt","id":"CVE-2020-15084","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Client caching login operation with plaintext password in Saleor Storefront","id":"CVE-2020-15085"},"packages":[{"ecosystem":"npm","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"express-jwt","purl":null,"source":"GHSA-6g6m-m6h5-w9gf"},{"ecosystem":"npm","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"express-jwt","purl":"pkg:npm/express-jwt","source":"GHSA-6g6m-m6h5-w9gf"}],"prev":{"headline":"Reflected XSS when uploading an image in the Product page in PrestaShop","id":"CVE-2020-15083"},"products":["express-jwt"],"published":"2020-06-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["auth0"]},"summary":"Attackers can bypass authorization in express-jwt if algorithms are not configured, allowing unauthorized access to protected resources.","url":"https://insights.sbomify.com/CVE-2020-15084/"}