# CVE-2020-15084: Authorization bypass in express-jwt

> Attackers can bypass authorization in express-jwt if algorithms are not configured, allowing unauthorized access to protected resources.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLSA-2026-1774570939, CLSA-2026-1774570940, GHSA-6g6m-m6h5-w9gf, ROOT-APP-NPM-CVE-2020-15084

## What is CVE-2020-15084?

CVE-2020-15084 is a high-severity authentication bypass vulnerability in auth0 express-jwt, published on 30 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In express-jwt (NPM package) up and including version 5.3.3, the algorithms entry to be specified in the configuration is not being enforced. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. You are affected by this vulnerability if all of the following conditions apply: - You are using express-jwt - You do not have **algorithms** configured in your express-jwt configuration. - You are using libraries such as jwks-rsa as the **secret**. You can fix this by specifying **algorithms** in the express-jwt configuration. See linked GHSA for example. This is also fixed in version 6.0.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-15084?

2 open source packages ship an affected version, including express-jwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-jwt` | npm | All versions | 6.0.0 |
| `express-jwt` | npm | All versions | 6.0.0 |

Products: Auth0 Express-Jwt.

## How do I fix CVE-2020-15084?

Upgrade express-jwt to 6.0.0 or later.

## Is CVE-2020-15084 being exploited?

There is no known exploitation of CVE-2020-15084 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15084 and fix it if it is affected.

What it is: CVE-2020-15084 is a high-severity authentication bypass vulnerability in auth0 express-jwt, published on 30 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15084 in the wild and no public exploit code.

Affected packages and fixed versions:
- express-jwt (npm): affected all versions; fixed in 6.0.0
- express-jwt (npm): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15084/ (Markdown: https://insights.sbomify.com/CVE-2020-15084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15084
- OSV: https://osv.dev/vulnerability/CVE-2020-15084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15084/
Summaries are generated and may contain mistakes; the official description above is the record.
