{"answers":{"affected":"2 open source packages ship an affected version, including friendsoftypo3/mediace. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15086 in the wild and no public exploit code.","fix":"Upgrade friendsoftypo3/mediace to 7.6.5 or later.","what":"CVE-2020-15086 is a critical unsafe deserialization vulnerability in FriendsOfTYPO3 mediace, published on 29 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15086 and fix it if it is affected.\n\nWhat it is: CVE-2020-15086 is a critical unsafe deserialization vulnerability in FriendsOfTYPO3 mediace, published on 29 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15086 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- friendsoftypo3/mediace (Packagist): affected from 7.6.2; fixed in 7.6.5\n- friendsoftypo3/mediace (Packagist): affected from 7.6.2; fixed in 7.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15086/ (Markdown: https://insights.sbomify.com/CVE-2020-15086/index.md)","id":"CVE-2020-15086","markdown":"https://insights.sbomify.com/CVE-2020-15086/index.md","name":"CVE-2020-15086","record":{"aliases":["GHSA-4h44-w6fm-548g"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"TYPO3 mediace extension","requires_auth":"none","summary":"Attackers with access to an Extbase plugin can inject arbitrary data with valid checksums, leading to remote code execution in TYPO3 installations using the mediace extension.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mediace","vendor":"typo3"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-325","name":"Missing Cryptographic Step"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"},{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In TYPO3 installations with the \"mediace\" extension from version 7.6.2 and before version 7.6.5, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. The allows to inject arbitrary data having a valid cryptographic message authentication code and can lead to remote code execution. To successfully exploit this vulnerability, an attacker must have access to at least one `Extbase` plugin or module action in a TYPO3 installation. This is fixed in version 7.6.5 of the \"mediace\" extension for TYPO3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential Remote Code Execution in TYPO3 with mediace extension","id":"CVE-2020-15086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Privilege escalation in Presto","id":"CVE-2020-15087"},"packages":[{"ecosystem":"Packagist","fixed":["7.6.5"],"introduced":["7.6.2"],"last_affected":[],"package":"friendsoftypo3/mediace","purl":null,"source":"GHSA-4h44-w6fm-548g"},{"ecosystem":"Packagist","fixed":["7.6.5"],"introduced":["7.6.2"],"last_affected":[],"package":"friendsoftypo3/mediace","purl":"pkg:composer/friendsoftypo3/mediace","source":"GHSA-4h44-w6fm-548g"}],"prev":{"headline":"Client caching login operation with plaintext password in Saleor Storefront","id":"CVE-2020-15085"},"products":["mediace"],"published":"2020-07-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["FriendsOfTYPO3"]},"summary":"Attackers with access to an Extbase plugin can inject arbitrary data with valid checksums, leading to remote code execution in TYPO3 installations using the mediace extension.","url":"https://insights.sbomify.com/CVE-2020-15086/"}