# CVE-2020-15094: RCE in Symfony

> Attackers can achieve remote code execution in Symfony applications using CachingHttpClient if they control the response of a cached request.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-symfony-2020-15094, DEBIAN-CVE-2020-15094, GHSA-754h-5r27-7x3r

## What is CVE-2020-15094?

CVE-2020-15094 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 2 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Symfony before versions 4.4.13 and 5.1.5, the CachingHttpClient class from the HttpClient Symfony component relies on the HttpCache class to handle requests. HttpCache uses internal headers like X-Body-Eval and X-Body-File to control the restoration of cached responses. The class was initially written with surrogate caching and ESI support in mind (all HTTP calls come from a trusted backend in that scenario). But when used by CachingHttpClient and if an attacker can control the response for a request being made by the CachingHttpClient, remote code execution is possible. This has been fixed in versions 4.4.13 and 5.1.5.

Weakness: CWE-212 (Improper Removal of Sensitive Information Before Storage or Transfer)

## Which versions are affected by CVE-2020-15094?

9 open source packages ship an affected version, including symfony/http-kernel, symfony and symfony/symfony. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/http-kernel` | Packagist | From 4.3.0 | 4.4.13 |
| `symfony/http-kernel` | Packagist | From 4.3.0 | 4.4.13 |
| `symfony/http-kernel` | Packagist | From 5.0.0 | 5.1.5 |
| `symfony/http-kernel` | Packagist | From 5.0.0 | 5.1.5 |
| `symfony` | Bitnami | From 4.4.0 | 4.4.13, 5.1.5 |
| `symfony/symfony` | Packagist | From 4.3.0 | 4.4.13 |
| `symfony/symfony` | Packagist | From 4.3.0 | 4.4.13 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.1.5 |
| `symfony/symfony` | Packagist | From 5.0.0 | 5.1.5 |

Products: Fedoraproject Fedora, Sensiolabs Httpclient, Sensiolabs Symfony.

## How do I fix CVE-2020-15094?

Upgrade symfony/http-kernel to a fixed version for your release line: 4.4.13 or 5.1.5.

## Is CVE-2020-15094 being exploited?

There is no known exploitation of CVE-2020-15094 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15094 and fix it if it is affected.

What it is: CVE-2020-15094 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 2 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15094 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/http-kernel (Packagist): affected from 4.3.0; fixed in 4.4.13
- symfony/http-kernel (Packagist): affected from 4.3.0; fixed in 4.4.13
- symfony/http-kernel (Packagist): affected from 5.0.0; fixed in 5.1.5
- symfony/http-kernel (Packagist): affected from 5.0.0; fixed in 5.1.5
- symfony (Bitnami): affected from 4.4.0; fixed in 4.4.13, 5.1.5
- symfony/symfony (Packagist): affected from 4.3.0; fixed in 4.4.13
- symfony/symfony (Packagist): affected from 4.3.0; fixed in 4.4.13
- symfony/symfony (Packagist): affected from 5.0.0; fixed in 5.1.5
- symfony/symfony (Packagist): affected from 5.0.0; fixed in 5.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15094/ (Markdown: https://insights.sbomify.com/CVE-2020-15094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15094
- OSV: https://osv.dev/vulnerability/CVE-2020-15094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15094/
Summaries are generated and may contain mistakes; the official description above is the record.
