CVE-2020-15095 Sensitive information exposure through logs in npm cli
The npm CLI exposes sensitive passwords in log files and stdout when using URLs with credentials, allowing attackers to read them.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15095?
CVE-2020-15095 is a medium-severity vulnerability in Fedoraproject Fedora, published on 7 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like "<protocol>://[<user>[:<password>]@]<hostname>[:<port>][:][/]<path>". The password value is not redacted and is printed to stdout and also to any generated log files.
Weakness: CWE-532
Which versions are affected by CVE-2020-15095?
2 open source packages ship an affected version, including npm. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
npm npm | All versions | 6.14.6 |
npm npm | All versions | 6.14.6 |
Linux distribution packages (2)
nodejs8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP1 | All versions | 8.17.0-3.38.1 |
nodejs8 openSUSE:Leap 15.1 | All versions | 8.17.0-lp151.2.21.1 |
Products include Fedoraproject Fedora, Npmjs Npm, Opensuse Leap.
How do I fix CVE-2020-15095?
Upgrade npm to 6.14.6 or later.
Is CVE-2020-15095 being exploited?
There is no known exploitation of CVE-2020-15095 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as CLSA-2026-1783299713, DEBIAN-CVE-2020-15095, GHSA-93f3-23rq-pjfp, SUSE-SU-2020:2870-1, UBUNTU-CVE-2020-15095, openSUSE-SU-2020:1644-1.