CVE-2020-15098 Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS
Authenticated attackers can forge HMAC checksums to inject data, potentially leading to privilege escalation and remote code execution in TYPO3 CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15098?
CVE-2020-15098 is a high-severity vulnerability in Typo3 Typo3, published on 29 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.20, and greater than or equal to 10.0.0 and less than 10.4.6, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains including potential privilege escalation, insecure deserialization & remote code execution. The overall severity of this vulnerability is high based on mentioned attack chains and the requirement of having a valid backend user session (authenticated). This has been patched in versions 9.5.20 and 10.4.6.
Which versions are affected by CVE-2020-15098?
9 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0.0 | 10.4.6 |
typo3/cms Packagist | From 10.0.0 | 10.4.6 |
typo3/cms Packagist | From 9.0.0 | 9.5.20 |
typo3/cms Packagist | From 9.0.0 | 9.5.20 |
typo3 Bitnami | From 9.0.0 | 9.5.20, 10.4.6 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.6 |
3 more packages
typo3/cms-core Packagist | From 10.0.0 | 10.4.6 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.20 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.20 |
Products include Typo3 Typo3.
How do I fix CVE-2020-15098?
Upgrade typo3/cms to a fixed version for your release line: 10.4.6 or 9.5.20.
Is CVE-2020-15098 being exploited?
There is no known exploitation of CVE-2020-15098 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2020-15098, GHSA-m5vr-3m74-jwxp.