# CVE-2020-15098: Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS

> Authenticated attackers can forge HMAC checksums to inject data, potentially leading to privilege escalation and remote code execution in TYPO3 CMS.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-typo3-2020-15098, GHSA-m5vr-3m74-jwxp

## What is CVE-2020-15098?

CVE-2020-15098 is a high-severity vulnerability in Typo3 Typo3, published on 29 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.20, and greater than or equal to 10.0.0 and less than 10.4.6, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains including potential privilege escalation, insecure deserialization & remote code execution. The overall severity of this vulnerability is high based on mentioned attack chains and the requirement of having a valid backend user session (authenticated). This has been patched in versions 9.5.20 and 10.4.6.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm), CWE-325 (Missing Cryptographic Step), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15098?

9 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.6 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.6 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.20 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.20 |
| `typo3` | Bitnami | From 9.0.0 | 9.5.20, 10.4.6 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.6 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.6 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.20 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.20 |

Products: Typo3 Typo3.

## How do I fix CVE-2020-15098?

Upgrade typo3/cms to a fixed version for your release line: 10.4.6 or 9.5.20.

## Is CVE-2020-15098 being exploited?

There is no known exploitation of CVE-2020-15098 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15098 and fix it if it is affected.

What it is: CVE-2020-15098 is a high-severity vulnerability in Typo3 Typo3, published on 29 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15098 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.6
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.6
- typo3/cms (Packagist): affected from 9.0.0; fixed in 9.5.20
- typo3/cms (Packagist): affected from 9.0.0; fixed in 9.5.20
- typo3 (Bitnami): affected from 9.0.0; fixed in 9.5.20, 10.4.6
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.6
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.6
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.20
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15098/ (Markdown: https://insights.sbomify.com/CVE-2020-15098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15098
- OSV: https://osv.dev/vulnerability/CVE-2020-15098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15098/
Summaries are generated and may contain mistakes; the official description above is the record.
