# CVE-2020-15103: Integer Overflow in FreeRDP

> A malicious RDP server can cause a client crash via integer overflow in the rdpegfx channel due to missing input validation.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2024-LS41715, DEBIAN-CVE-2020-15103, GHSA-4r38-6hq7-j3j9, OESA-2023-1719, SUSE-SU-2020:2408-1, SUSE-SU-2020:2409-1, UBUNTU-CVE-2020-15103, openSUSE-SU-2020:1332-1

## What is CVE-2020-15103?

CVE-2020-15103 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 27 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In FreeRDP less than or equal to 2.1.2, an integer overflow exists due to missing input sanitation in rdpegfx channel. All FreeRDP clients are affected. The input rectangles from the server are not checked against local surface coordinates and blindly accepted. A malicious server can send data that will crash the client later on (invalid length arguments to a `memcpy`) This has been fixed in 2.2.0. As a workaround, stop using command line arguments /gfx, /gfx-h264 and /network:auto

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-680 (Integer Overflow to Buffer Overflow)

## Which versions are affected by CVE-2020-15103?

It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `freerdp` | SUSE:Linux Enterprise Workstation Extension 15 SP1 | All versions | 2.1.2-10.18.1 |
| `freerdp` | SUSE:Linux Enterprise Workstation Extension 15 SP2 | All versions | 2.1.2-15.10.1 |
| `freerdp` | openSUSE:Leap 15.1 | All versions | 2.1.2-lp151.5.9.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Freerdp Freerdp, Opensuse Leap.

## How do I fix CVE-2020-15103?

Upgrade to a fixed version.

## Is CVE-2020-15103 being exploited?

There is no known exploitation of CVE-2020-15103 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15103 and fix it if it is affected.

What it is: CVE-2020-15103 is a low-severity vulnerability in Canonical Ubuntu Linux, published on 27 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15103 in the wild and no public exploit code.

Affected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15103/ (Markdown: https://insights.sbomify.com/CVE-2020-15103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15103
- OSV: https://osv.dev/vulnerability/CVE-2020-15103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15103/
Summaries are generated and may contain mistakes; the official description above is the record.
