CVE-2020-15104 TLS Validation Vulnerability in Envoy
Envoy incorrectly validates wildcard TLS certificates, allowing attackers to bypass subject alternative name checks in specific configurations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15104?
CVE-2020-15104 is a medium-severity vulnerability in Envoyproxy Envoy, published on 14 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Envoy before versions 1.12.6, 1.13.4, 1.14.4, and 1.15.0 when validating TLS certificates, Envoy would incorrectly allow a wildcard DNS Subject Alternative Name apply to multiple subdomains. For example, with a SAN of *.example.com, Envoy would incorrectly allow nested.subdomain.example.com, when it should only allow subdomain.example.com. This defect applies to both validating a client TLS certificate in mTLS, and validating a server TLS certificate for upstream connections. This vulnerability is only applicable to situations where an untrusted entity can obtain a signed wildcard TLS certificate for a domain of which you only intend to trust a subdomain of. For example, if you intend to trust api.mysubdomain.example.com, and an untrusted actor can obtain a signed TLS certificate for *.example.com or *.com. Configurations are vulnerable if they use verify_subject_alt_name in any Envoy version, or if they use match_subject_alt_names in version 1.14 or later. This issue has been fixed in Envoy versions 1.12.6, 1.13.4, 1.14.4, 1.15.0.
Weakness: CWE-346
Which versions are affected by CVE-2020-15104?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | All versions | 1.12.6, 1.13.4, 1.14.4 |
Linux distribution packages (1)
servicemesh-proxy Red Hat:service_mesh:1.1::el8 | All versions | 0:1.1.5-1.el8 |
Products include Envoyproxy Envoy.
How do I fix CVE-2020-15104?
Upgrade envoy to a fixed version for your release line: 1.12.6, 1.13.4 or 1.14.4.
Is CVE-2020-15104 being exploited?
There is no known exploitation of CVE-2020-15104 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2020-15104, GHSA-w5f5-6qhq-hhrg, RHSA-2020:3090.