# CVE-2020-15104: TLS Validation Vulnerability in Envoy

> Envoy incorrectly validates wildcard TLS certificates, allowing attackers to bypass subject alternative name checks in specific configurations.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-envoy-2020-15104, GHSA-w5f5-6qhq-hhrg, RHSA-2020:3090

## What is CVE-2020-15104?

CVE-2020-15104 is a medium-severity vulnerability in Envoyproxy Envoy, published on 14 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Envoy before versions 1.12.6, 1.13.4, 1.14.4, and 1.15.0 when validating TLS certificates, Envoy would incorrectly allow a wildcard DNS Subject Alternative Name apply to multiple subdomains. For example, with a SAN of *.example.com, Envoy would incorrectly allow nested.subdomain.example.com, when it should only allow subdomain.example.com. This defect applies to both validating a client TLS certificate in mTLS, and validating a server TLS certificate for upstream connections. This vulnerability is only applicable to situations where an untrusted entity can obtain a signed wildcard TLS certificate for a domain of which you only intend to trust a subdomain of. For example, if you intend to trust api.mysubdomain.example.com, and an untrusted actor can obtain a signed TLS certificate for *.example.com or *.com. Configurations are vulnerable if they use verify_subject_alt_name in any Envoy version, or if they use match_subject_alt_names in version 1.14 or later. This issue has been fixed in Envoy versions 1.12.6, 1.13.4, 1.14.4, 1.15.0.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2020-15104?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.12.6, 1.13.4, 1.14.4 |
| `servicemesh-proxy` | Red Hat:service_mesh:1.1::el8 | All versions | 0:1.1.5-1.el8 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2020-15104?

Upgrade envoy to a fixed version for your release line: 1.12.6, 1.13.4 or 1.14.4.

## Is CVE-2020-15104 being exploited?

There is no known exploitation of CVE-2020-15104 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15104 and fix it if it is affected.

What it is: CVE-2020-15104 is a medium-severity vulnerability in Envoyproxy Envoy, published on 14 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15104 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.12.6, 1.13.4, 1.14.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15104/ (Markdown: https://insights.sbomify.com/CVE-2020-15104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15104
- OSV: https://osv.dev/vulnerability/CVE-2020-15104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15104/
Summaries are generated and may contain mistakes; the official description above is the record.
