{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15107 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-15107 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-15107 is a medium-severity vulnerability in openenclave, published on 15 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15107 and fix it if it is affected.\n\nWhat it is: CVE-2020-15107 is a medium-severity vulnerability in openenclave, published on 15 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15107 in the wild and no public exploit code.\n\nAffected product: openenclave. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15107/ (Markdown: https://insights.sbomify.com/CVE-2020-15107/index.md)","id":"CVE-2020-15107","markdown":"https://insights.sbomify.com/CVE-2020-15107/index.md","name":"CVE-2020-15107","record":{"aliases":["GHSA-7wjx-wcwg-w999"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Open Enclave SDK","requires_auth":"low_privilege","summary":"A malicious host can compromise enclave execution integrity or mount side-channel attacks via x87 FPU ABI violations in Open Enclave SDK.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openenclave","vendor":"openenclave"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[],"description":"In openenclave before 0.10.0, enclaves that use x87 FPU operations are vulnerable to tampering by a malicious host application. By violating the Linux System V Application Binary Interface (ABI) for such operations, a host app can compromise the execution integrity of some x87 FPU operations in an enclave. Depending on the FPU control configuration of the enclave app and whether the operations are used in secret-dependent execution paths, this vulnerability may also be used to mount a side-channel attack on the enclave. This has been fixed in 0.10.0 and the current master branch. Users will need to recompile their applications against the patched libraries to be protected from this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"x87 FPU operations in enclaves are vulnerable to ABI poisoning in openenclave","id":"CVE-2020-15107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2020"},"n_packages":0,"n_references":1,"next":{"headline":"SQL Injection in glpi","id":"CVE-2020-15108"},"packages":[],"prev":{"headline":"Improper Input Validation in etcd","id":"CVE-2020-15106"},"products":["openenclave"],"published":"2020-07-15","related":[{"cvss_score":6.8,"headline":"Socket syscalls can leak enclave memory contents in Open Enclave","id":"CVE-2020-15224","kev_date_added":null,"published":"2020-10-14"},{"cvss_score":5.3,"headline":"Improper sanitization of MXCSR and RFLAGS in OpenEnclave","id":"CVE-2023-37479","kev_date_added":null,"published":"2023-07-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["openenclave"]},"summary":"A malicious host can compromise enclave execution integrity or mount side-channel attacks via x87 FPU ABI violations in Open Enclave SDK.","url":"https://insights.sbomify.com/CVE-2020-15107/"}