# CVE-2020-15109: Ability to change order address without triggering address validations in solidus

> Attackers can modify order addresses without triggering validation, bypassing shipment cost calculations in stores with multiple shipping zones.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3mvg-rrrw-m7ph

## What is CVE-2020-15109?

CVE-2020-15109 is a medium-severity vulnerability in solidusio solidus, published on 4 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In solidus before versions 2.8.6, 2.9.6, and 2.10.2, there is an bility to change order address without triggering address validations. This vulnerability allows a malicious customer to craft request data with parameters that allow changing the address of the current order without changing the shipment costs associated with the new shipment. All stores with at least two shipping zones and different costs of shipment per zone are impacted. This problem comes from how checkout permitted attributes are structured. We have a single list of attributes that are permitted across the whole checkout, no matter the step that is being submitted. See the linked reference for more information. As a workaround, if it is not possible to upgrade to a supported patched version, please use this gist in the references section.

Weakness: CWE-862 (Missing Authorization), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15109?

12 open source packages ship an affected version, including solidus_api and solidus_frontend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `solidus_api` | RubyGems | All versions | 2.8.6 |
| `solidus_api` | RubyGems | All versions | 2.8.6 |
| `solidus_api` | RubyGems | From 2.10.0 | 2.10.2 |
| `solidus_api` | RubyGems | From 2.10.0 | 2.10.2 |
| `solidus_api` | RubyGems | From 2.9.0 | 2.9.6 |
| `solidus_api` | RubyGems | From 2.9.0 | 2.9.6 |
| `solidus_frontend` | RubyGems | All versions | 2.8.6 |
| `solidus_frontend` | RubyGems | All versions | 2.8.6 |
| `solidus_frontend` | RubyGems | From 2.10.0 | 2.10.2 |
| `solidus_frontend` | RubyGems | From 2.10.0 | 2.10.2 |
| `solidus_frontend` | RubyGems | From 2.9.0 | 2.9.6 |
| `solidus_frontend` | RubyGems | From 2.9.0 | 2.9.6 |

Products: Nebulab Solidus.

## How do I fix CVE-2020-15109?

Upgrade solidus_api to a fixed version for your release line: 2.8.6, 2.10.2 or 2.9.6.

## Is CVE-2020-15109 being exploited?

There is no known exploitation of CVE-2020-15109 in the wild and no public exploit code.

## Other vulnerabilities in solidusio solidus

- [CVE-2021-43805](https://insights.sbomify.com/CVE-2021-43805/): ReDos vulnerability on guest checkout email validation (high 7.5)
- [CVE-2021-43846](https://insights.sbomify.com/CVE-2021-43846/): CSRF forgery protection bypass for Spree::OrdersController#populate (medium 5.3)
- [CVE-2022-31000](https://insights.sbomify.com/CVE-2022-31000/): CSRF allows attacker to finalize/unfinalize order adjustments in solidus_backend (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15109 and fix it if it is affected.

What it is: CVE-2020-15109 is a medium-severity vulnerability in solidusio solidus, published on 4 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15109 in the wild and no public exploit code.

Affected packages and fixed versions:
- solidus_api (RubyGems): affected all versions; fixed in 2.8.6
- solidus_api (RubyGems): affected all versions; fixed in 2.8.6
- solidus_api (RubyGems): affected from 2.10.0; fixed in 2.10.2
- solidus_api (RubyGems): affected from 2.10.0; fixed in 2.10.2
- solidus_api (RubyGems): affected from 2.9.0; fixed in 2.9.6
- solidus_api (RubyGems): affected from 2.9.0; fixed in 2.9.6
- solidus_frontend (RubyGems): affected all versions; fixed in 2.8.6
- solidus_frontend (RubyGems): affected all versions; fixed in 2.8.6
- solidus_frontend (RubyGems): affected from 2.10.0; fixed in 2.10.2
- solidus_frontend (RubyGems): affected from 2.10.0; fixed in 2.10.2
- solidus_frontend (RubyGems): affected from 2.9.0; fixed in 2.9.6
- solidus_frontend (RubyGems): affected from 2.9.0; fixed in 2.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15109/ (Markdown: https://insights.sbomify.com/CVE-2020-15109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15109
- OSV: https://osv.dev/vulnerability/CVE-2020-15109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15109/
Summaries are generated and may contain mistakes; the official description above is the record.
