# CVE-2020-15110: Possible pod name collisions in jupyterhub-kubespawner

> Attackers can craft server names to access other users' default servers, leading to unauthorized access and privilege escalation in JupyterHub environments.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v7m9-9497-p9gr, PYSEC-2020-51

## What is CVE-2020-15110?

CVE-2020-15110 is a medium-severity missing authorization vulnerability in jupyterhub kubespawner, published on 17 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In jupyterhub-kubespawner before 0.12, certain usernames will be able to craft particular server names which will grant them access to the default server of other users who have matching usernames. This has been fixed in 0.12.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-15110?

3 open source packages ship an affected version, including jupyterhub-kubespawner. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterhub-kubespawner` | PyPI | All versions | 0.12.0 |
| `jupyterhub-kubespawner` | PyPI | All versions | 0.12.0 |
| `jupyterhub-kubespawner` | PyPI | All versions | 0.12.0 |

Products: Jupyterhub Kubespawner.

## How do I fix CVE-2020-15110?

Upgrade jupyterhub-kubespawner to 0.12.0 or later.

## Is CVE-2020-15110 being exploited?

There is no known exploitation of CVE-2020-15110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15110 and fix it if it is affected.

What it is: CVE-2020-15110 is a medium-severity missing authorization vulnerability in jupyterhub kubespawner, published on 17 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15110 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterhub-kubespawner (PyPI): affected all versions; fixed in 0.12.0
- jupyterhub-kubespawner (PyPI): affected all versions; fixed in 0.12.0
- jupyterhub-kubespawner (PyPI): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15110/ (Markdown: https://insights.sbomify.com/CVE-2020-15110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15110
- OSV: https://osv.dev/vulnerability/CVE-2020-15110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15110/
Summaries are generated and may contain mistakes; the official description above is the record.
