# CVE-2020-15113: Improper Preservation of Permissions in etcd

> Attackers can read or modify sensitive etcd data if directories are created with insecure permissions due to improper permission preservation.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-6390, BIT-etcd-2020-15113, DEBIAN-CVE-2020-15113, GHSA-chh6-ppwq-jh92, UBUNTU-CVE-2020-15113

## What is CVE-2020-15113?

CVE-2020-15113 is a medium-severity vulnerability in Fedoraproject Fedora, published on 5 Aug 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In etcd before versions 3.3.23 and 3.4.10, certain directory paths are created (etcd data directory and the directory path when provided to automatically generate self-signed certificates for TLS connections with clients) with restricted access permissions (700) by using the os.MkdirAll. This function does not perform any permission checks when a given directory path exists already. A possible workaround is to ensure the directories have the desired permission (700).

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2020-15113?

5 open source packages ship an affected version, including github.com/etcd-io/etcd and etcd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/etcd-io/etcd` | Go | All versions | 3.3.23 |
| `github.com/etcd-io/etcd` | Go | All versions | 3.3.23 |
| `github.com/etcd-io/etcd` | Go | From 3.4.0-rc.0 | 3.4.10 |
| `github.com/etcd-io/etcd` | Go | From 3.4.0-rc.0 | 3.4.10 |
| `etcd` | Bitnami | All versions | 3.3.23, 3.4.10 |

Products: Etcd Etcd, Fedoraproject Fedora.

## How do I fix CVE-2020-15113?

Upgrade github.com/etcd-io/etcd to a fixed version for your release line: 3.3.23 or 3.4.10.

## Is CVE-2020-15113 being exploited?

There is no known exploitation of CVE-2020-15113 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2021-28235](https://insights.sbomify.com/CVE-2021-28235/): Etcd-io Improper Authentication vulnerability (critical 9.8)
- [CVE-2026-33413](https://insights.sbomify.com/CVE-2026-33413/): etcd: Authorization bypasses in multiple APIs (high 8.8)
- [CVE-2022-34038](https://insights.sbomify.com/CVE-2022-34038/): Denial of service in n/a (high 7.5)
- [CVE-2018-16886](https://insights.sbomify.com/CVE-2018-16886/): go.etcd.io/etcd Authentication Bypass (medium 6.8)
- [CVE-2026-59818](https://insights.sbomify.com/CVE-2026-59818/): etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15113 and fix it if it is affected.

What it is: CVE-2020-15113 is a medium-severity vulnerability in Fedoraproject Fedora, published on 5 Aug 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15113 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/etcd-io/etcd (Go): affected all versions; fixed in 3.3.23
- github.com/etcd-io/etcd (Go): affected all versions; fixed in 3.3.23
- github.com/etcd-io/etcd (Go): affected from 3.4.0-rc.0; fixed in 3.4.10
- github.com/etcd-io/etcd (Go): affected from 3.4.0-rc.0; fixed in 3.4.10
- etcd (Bitnami): affected all versions; fixed in 3.3.23, 3.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15113/ (Markdown: https://insights.sbomify.com/CVE-2020-15113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15113
- OSV: https://osv.dev/vulnerability/CVE-2020-15113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15113/
Summaries are generated and may contain mistakes; the official description above is the record.
