CVE-2020-15115 No minimum password length in etcd
etcd allows weak passwords without length validation, enabling attackers to easily guess or brute-force credentials to gain unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15115?
CVE-2020-15115 is a medium-severity vulnerability in Fedoraproject Fedora, published on 6 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.
Weakness: CWE-521
Which versions are affected by CVE-2020-15115?
4 open source packages ship an affected version, including go.etcd.io/etcd/client/v3. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
go.etcd.io/etcd/client/v3 Go | All versions | 3.3.23 |
go.etcd.io/etcd/client/v3 Go | All versions | 3.3.23 |
go.etcd.io/etcd/client/v3 Go | From 3.4.0 | 3.4.10 |
go.etcd.io/etcd/client/v3 Go | From 3.4.0 | 3.4.10 |
Products include Fedoraproject Fedora, Redhat Etcd.
How do I fix CVE-2020-15115?
Upgrade go.etcd.io/etcd/client/v3 to a fixed version for your release line: 3.3.23 or 3.4.10.
Is CVE-2020-15115 being exploited?
There is no known exploitation of CVE-2020-15115 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as AZL-6392, DEBIAN-CVE-2020-15115, GHSA-4993-m7g5-r9hh, UBUNTU-CVE-2020-15115.